Page 1 of 2

GB Boy Colour power problem

Posted: Thu Mar 10, 2016 12:12 pm
by mister j-y
Hullo everyone! Haven't been on here for ages so I hope you're all doing well

I have a problem with my GB Boy Colour console and I'm hoping someone can help to diagnose the problem so that I can fix it - I would have just bought a new one, but as anyone who's read the main GB Boy Colour topic can see they've suddenly gone to ten times the price they were a couple of months ago! (Note: sorry mods if this is the wrong place to put this question)

So, I can get some power to the console, the red light turns on, but I have a blank screen. I realise this is about as unspecific as it gets, but can someone walk me through what I need to do next? The console has a weird screw/rivet (see pic, apologies for quality) that I can't recognise too, so any advice on getting the case open would be appreciated!

Re: GB Boy Colour power problem

Posted: Sat Mar 12, 2016 11:24 am
by Ziggy587
That's a security screw. There's two main sizes that most retro game consoles and carts use.

http://www.amazon.co.uk/DelTex%C2%AE-Ni ... rity+screw

I believe you will need the 3.8mm bit for the GBC system. Note that these can vary a lot in quality. The cheaper quality ones can be hard to use.

But before you start taking apart your GBC... You say the power light comes on but you get nothing on the screen. Is there no audio as well? It could just be a dirty cart slot and/or dirty carts.

Re: GB Boy Colour power problem

Posted: Mon Mar 14, 2016 9:58 am
by mister j-y
Ziggy587 wrote:...before you start taking apart your GBC... You say the power light comes on but you get nothing on the screen. Is there no audio as well? It could just be a dirty cart slot and/or dirty carts.



Thanks for the reply Ziggy! It's a GB Boy Colour (so the GBC clone with backlight) and it ought to at least turn on with no cart present (it's got built-in games) - however I've tried with the cart I was playing on it (Super Mario 6 Golden Coins) as well as without so that it would normally boot to the built-in games menu and I get no sound or screen action at all! I'll have a look for those security bit screw drivers too, thanks mate

Re: GB Boy Colour power problem

Posted: Tue Mar 15, 2016 8:30 am
by WARvault
My GB Boy Colour always acts screwy if the batteries are even a little flat.

Re: GB Boy Colour power problem

Posted: Wed Mar 16, 2016 10:33 am
by mister j-y
WARvault wrote:My GB Boy Colour always acts screwy if the batteries are even a little flat.


I reckon that may have something to do with it, as when this first happened I had new batteries in and they appeared to run out quickly - only to be re-used in my GBA with no problem. Hmmm, how to fix?

Re: GB Boy Colour power problem

Posted: Sun Mar 20, 2016 8:59 pm
by WARvault
mister j-y wrote:
WARvault wrote:My GB Boy Colour always acts screwy if the batteries are even a little flat.


I reckon that may have something to do with it, as when this first happened I had new batteries in and they appeared to run out quickly - only to be re-used in my GBA with no problem. Hmmm, how to fix?



Its a feature! :?

Re: GB Boy Colour power problem

Posted: Mon Mar 21, 2016 11:32 am
by mister j-y
WARvault wrote:Its a feature! :?

Dammit! :(

Re: GB Boy Colour power problem

Posted: Mon Aug 29, 2016 3:30 pm
by NahuelDS
Hi! I have the exact same problem.
LED lights up, but the display is dead and there is no sound.

I've been using it with 1.2V AA rechargeable batteries with some issues: the console resets when the batteries are low on charge. Especially if I use my Everdrive GB (which requires more power).

This morning the display started flickering and then the console started resetting itself. I switched to couple of 1.5V AA standard batteries (because I though the rechargeable batteries were dead) but the console died.

Maybe the caps are blown, but I don't see any damage or leak. Maybe someone with more knowledge could take a look.

Re: GB Boy Colour power problem

Posted: Fri Aug 11, 2017 4:37 pm
by Tanooki
Resurrection!

I'm having a little bit of an issue here, search on google/krikzz forum has no resolution and just a lot of competing conversations.

Everdrive GB while attempting to use it, the system on battery power (off the shelf duracell standard batteries) it perpetually resets the GB Boy Colour on the GB Boy Colour boot screen, doesn't get to the kit, but using a stock GB game it's fine. EDGB works fine in my SP, not sure what the deal is here.

I'm thinking most come across a power loss causing it, so what do you do? Rechargeable batteries tend to be 1.2v which the loss of .3v probably make things worse. 1.5v is standard, been reading somewhere a 1.6v battery for AA exists.

Any ideas?

Re: GB Boy Colour power problem

Posted: Sat Aug 12, 2017 2:41 am
by nightrnr
Well, I too can attest to the lower battery power causing issues. I tried playing DWIII on it with rechargeables and it just resets whenever it feels like. Fresh alkalines made it better, but I don't trust it now. playing an RPG just to have it reset on you without warning would suck so much.
Rechargeables seem to play the built-in games well enough though. Maybe GB games are better and GBC requires more juice from it?

An everdrive would probably exacerbate the situation, as suspected. I'm not sure there are any fixes for the GB Boy Colour regarding this.
It's funny that it's gotten pricey, as I don't think that it has much practical value. It's been a mild disappointment for me (but works well for a Kirby Tilt n tumble backlit system.