Need help with your PC or Modding Projects?
User avatar
Ghudda
128-bit
 
Posts: 520
Joined: Thu Nov 07, 2013 12:47 pm
Location: North Texas

JVC X'eye repair log (warning: spiders)

by Ghudda Thu Jan 21, 2016 6:45 pm

Picked up a non-working JVC X'eye on eBay on the cheap and am about to begin the process of attempting to repair it. I know really nothing about this unit, but I thought it'd be worth a shot. I'll post some detailed pictures of the boards here in a bit to see if anyone spots anything funky. I ordered a cap replacement kit from Console 5 and will be replacing the capacitors ASAP.

The problem: Console powers up but I get a black screen. Not even the BIOS splash screen. Genesis nor CD games work at the moment.

This thing was FILTHY. Smelled like cigarettes and dusty storage closet. Not sure how far I'm going to get with this thing, but I'm somewhat confident I can get it up and running again. I'm currently washing the chassis and will further inspect the board when I get some time later.

STAY TUNED

What's that...?
Image
NOPE
Image
User avatar
noiseredux
Next-Gen
 
Posts: 38149
Joined: Fri Nov 14, 2008 1:09 pm

Re: JVC X'eye repair log (warning: spiders)

by noiseredux Thu Jan 21, 2016 7:23 pm

Please tell me I inspired this purchase.
Image
User avatar
Ghudda
128-bit
 
Posts: 520
Joined: Thu Nov 07, 2013 12:47 pm
Location: North Texas

Re: JVC X'eye repair log (warning: spiders)

by Ghudda Thu Jan 21, 2016 7:33 pm

noiseredux wrote:Please tell me I inspired this purchase.

Confirmed 8)
User avatar
flojocabron
Next-Gen
 
Posts: 4155
Joined: Thu Aug 19, 2010 2:15 am
Location: on the border

Re: JVC X'eye repair log (warning: spiders)

by flojocabron Fri Jan 22, 2016 12:51 am

Image

Come on man? Why'd you have to be so harsh? We only want to play some retro games with you!
2600 and jr,5200,nes/top loader, master system, intellivision, TG-16, genesis 1,2,3, SNES, snesJR, CDX, 3DOfz10, gamegear, gameboy and pocket, GBC, sega saturn, PSOne w/screen, Virtual Boy, N64, NGPC, Gameboy Advance sp, Dreamcast, Black Dreamcast, oXBOX, Playstation 2, PStwo, Gamecube, gameboy player, DS lite,DSi XL, PSP1000/3000,Wii,PS3 120gb,3DSXL, xbox 360, PSvita, PS4
User avatar
ElkinFencer10
Next-Gen
 
Posts: 7740
Joined: Fri Aug 13, 2010 8:34 pm
Location: Henderson, North Carolina

Re: JVC X'eye repair log (warning: spiders)

by ElkinFencer10 Fri Jan 22, 2016 10:35 am

Douse it with gasoline and burn it. It's the only way to cleanse the evil.
Exhuminator wrote:Ecchi lords must unite for great justice.

Image
User avatar
ApolloBoy
128-bit
 
Posts: 954
Joined: Mon Nov 15, 2010 8:56 pm
Location: San Jose, CA

Re: JVC X'eye repair log (warning: spiders)

by ApolloBoy Fri Jan 22, 2016 1:40 pm

Reminds me of when I bought my 5200 about 12 years ago; it looked like it had been in a flood or something and to top it off, I discovered an egg sac complete with a few live spiders. Needless to say it's doing a lot better these days.
Own: 2600, 2DS, 2DS XL, 360 S, 5200, 7800, 800, 800XL, AES, Amiga 600, C64, C64C, CV, DC, Duo-R, GB, GBA, GBA SP, GBC, GBP, Genesis 2, GG, JP SMS, Lynx, Mark III, Mega CD II, MD, MSX2+, N64, NES, NES top loader, Nomad, PCE, PSX, PS2, RetroUSB AVS, SAT, SFC, SG-1000 II, SMS, SNES mini, Switch, TE, Twin Fami, VIC-20, Wii, XEGS
User avatar
Ghudda
128-bit
 
Posts: 520
Joined: Thu Nov 07, 2013 12:47 pm
Location: North Texas

Re: JVC X'eye repair log (warning: spiders)

by Ghudda Tue Jan 26, 2016 12:16 am

Update: I replaced the capacitors on both the main and daughter boards, and still nothing.

The console will power on, but I never make it to the BIOS splash screen. The LED's light up on the daughter board (including the CD drive which makes a click noise), but the BIOS never kicks in. So it looks like the board is getting power properly, but it's still unresponsive. My PVM does recognize the video input, as it registers it as NTSC.

I checked for any corrosion around the BIOS chip, etc. and didn't see anything.

Anyone have any ideas for troubleshooting the lack of a splash screen?

I'm using the official PSU (Model AA-S95J)

EDIT: Soon after posting this, I was investigating more of the chips on the main board and notice that a few legs on the SRAM chip have experienced some corrosion. I took my multi-meter and checked for continuity between each leg and the corresponding point, and some of it looks shaky, so I guess i'll need to bridge some of the traces?

Image
User avatar
noiseredux
Next-Gen
 
Posts: 38149
Joined: Fri Nov 14, 2008 1:09 pm

Re: JVC X'eye repair log (warning: spiders)

by noiseredux Tue Jan 26, 2016 9:02 am

wish I could help but you're much smarter than I am. It's exciting to follow along with your progress though.
Image
User avatar
samsonlonghair
Next-Gen
 
Posts: 5188
Joined: Tue Feb 17, 2009 2:11 pm
Location: Now: Newport News, VA. Formerly: Richmond. Before that: Near the WV/VA border

Re: JVC X'eye repair log (warning: spiders)

by samsonlonghair Tue Jan 26, 2016 9:40 am

Likewise, I don't have the technical skills to help with this, but I'm following along with anticipation. I'm rooting for you, Ghudda.
User avatar
noiseredux
Next-Gen
 
Posts: 38149
Joined: Fri Nov 14, 2008 1:09 pm

Re: JVC X'eye repair log (warning: spiders)

by noiseredux Tue Jan 26, 2016 9:54 am

Image
Image
Return to Technical Help

Who is online

Users browsing this forum: No registered users and 5 guests